Buscar datos hacia la izquierda

Muy buenas a todos,

Me imagino, que al igual que yo, os habeis encontrado alguna vez con una tabla en la cual vais a buscar datos, y os disponeis a formular un buscarv hasta que os dais cuenta de que el dato que vais a buscar está a la izquierda del valor buscado o de referencia. Bien es cierto que la solucion mas sencilla es cortar esa columna y llevarla a la derecha de la columna donde vamos a buscar, pero en cuento tengamos un numero de filas majo (con mi fichero de ventas, que aculuma 60 mil filas al mes imposible…) simplemente ese cambio puede hacer que sea inestable el fichero.

La solucion que os traigo para buscar datos hacia la izquierda pasa por utilizar de forma anidada las funciones INDICE y COINCIDIR.
La funcion coincidir ya la hemos explicado en otros post pero sin embargo es la primera vez que usamos la funcion INDICE asique vamos a explicarla de forma sencilla mientras avanzamos con el ejemplo.

Partimos de una tabla, en este caso reutilizo la del post Buscarv y Coincidir en la cual teniamos distintos clientes con sus direcciones y delegados.
Buscarv_y_Coincidir_1

La funcion Indice es como jugar a los barquitos, vamos a seleccionar una tabla, y darle el numero de fila y columna (o solo un valor si la seleccion tiene solo una dimension) y nos va adevolver el valor alli alojado.
Para tomar el ejemplo vamos a montar la formula para toda la tabla y que nos devuelva el valor como si jugasemos a los barquitos, para ello, escribimos la siguente formula en C23:
=INDICE(A1:G20;C24;C25)
Lo que le estamos diciendo es que le vamos a escribir en C24 y C25 la fila y la celda respectivamente del valor que nos va a devoler, de manera que si escribimos 2 y 4, por ejemplo, nos va a devolver el valor de la celda D2 (la cuarta columna de la tabla, segunda fila de la misma)
Buscar_izda_2
Ahora podemos jugar cambiando estos valores para obtener el resultado deseado, sabiando que el numero maximo de filas es 20 y de columnas 7.

Muy bien, ¿y para que me sirve esto si no se el numero? Ahi es donde entra la funcion coincidir. Lo que vamos a hacer es usar el coincidir para que nos de el numero de fila o de celda que ocupa el valor que estamos buscando, y luego utilizarlo para que nos devuelva el valor deseado, de manera que podamos buscar datos hacia la izquierda.
En nuestro caso vamos a buscar los codigos de cliente en funcion del nombre de la farmacia, de la siguente manera:
Buscar_izda_3
Entonces metemos la formula siguente en C29:
=INDICE($A$1:$A$20;COINCIDIR($B29;$B$1:$B$20;0))
Para comprender la formula lo vemos en la imagen siguiente:
Buscar_izda_4

    • $A$1:$A$20 indica el rango del que vamos a obtener el valor, obviamente es la columna correspondiente al numero de cliente.
    • COINCIDIR($B29;$B$1:$B$20

indica que nos devuelva aquel numero de fila que representa B29 en el rango B1:B20, es decir, buscamos la fila del valor.

De esta manera obtenemos el numero de cliente, que es 3 y ademas, como hemos formulado con dolar, podemos arrastrar hacia abajo la formula.
Buscar_izda_5

Como veis, buscar datos hacia la izquierda no es dificil si utilizamos esta nidacion de formulas.

Saludos

2 Comments

  1. Leonardo B 27/03/2020

Leave a Reply

Tu dirección de correo electrónico no será publicada.

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información.

ACEPTAR
Aviso de cookies
istanbul escortistanbul escortistanbul escortistanbul escortistanbul escortistanbul escort
istanbul escortistanbul escortistanbul escortistanbul escortistanbul escortistanbul escort
istanbul escortistanbul escortistanbul escortistanbul escortistanbul escortistanbul escort
istanbul escortistanbul escortistanbul escortistanbul escortistanbul escortistanbul escortistanbul escortistanbul escort
ataşehir escortataşehir escortataşehir escortataşehir escortataşehir escortataşehir escortataşehir escortataşehir escortataşehir escort
ataşehir escortataşehir escortataşehir escortataşehir escortataşehir escortataşehir escortataşehir escortataşehir escort
dubai escortsdubai escortsdubai escortsdubai escortsdubai escortsdubai escortsdubai escortsdubai escorts